低代码引擎-基于 Low-Code Engine 快速打造高生产力的低代码研发平台
美国
优质开源项目 JavaScript 优质开源项目
低代码引擎-基于 Low-Code Engine 快速打造高生产力的低代码研发平台

基于 Low-Code Engine 快速打造高生产力的低代码研发平台

标签:

✨ 特性

  • 🌈 提炼自企业级低代码平台的面向扩展设计的内核引擎,奉行最小内核,最强生态的设计理念
  • 📦 开箱即用的高质量生态元素,包括 物料体系、设置器、插件 等
  • ⚙️ 完善的工具链,支持 物料体系、设置器、插件 等生态元素的全链路研发周期
  • 🔌 强大的扩展能力,已支撑近 100 个各种垂直类低代码平台
  • 🛡 使用 TypeScript 开发,提供完整的类型定义文件

🎯 兼容环境

  • 现代浏览器(Chrome >= 80, Edge >= 80, last 2 safari versions, last 2 firefox versions)

📚 引擎协议

引擎完整实现了《阿里巴巴中后台前端基础搭建协议规范》和《阿里巴巴中后台前端物料协议规范》,协议栈是低代码领域的物料能否流通的关键部分。

低代码引擎-基于 Low-Code Engine 快速打造高生产力的低代码研发平台

🌰 使用示例

npm install @alilc/lowcode-engine --save-dev

TIPS:仅支持 cdn 方式引入,npm 包用于提供 typings 等代码提示能力

import { init, skeleton } from '@alilc/lowcode-engine';

skeleton.add({
  area: 'topArea',
  type: 'Widget',
  name: 'logo',
  content: YourFantaticLogo,
  contentProps: {
    logo:
      'https://img.alicdn.com/tfs/TB1_SocGkT2gK0jSZFkXXcIQFXa-66-66.png',
    href: '/',
  },
  props: {
    align: 'left',
    width: 100,
  },
});

init(document.getElementById('lce'));

工程化配置:

{
  "externals": {
    "@alilc/lowcode-engine": "var window.AliLowCodeEngine",
    "@alilc/lowcode-engine-ext": "var window.AliLowCodeEngineExt"
  }
}

cdn 可选方式:

方式 1(推荐):alifd cdn

https://alifd.alicdn.com/npm/@alilc/lowcode-engine@1.0.0/dist/js/engine-core.js

https://alifd.alicdn.com/npm/@alilc/lowcode-react-simulator-renderer@1.0.0/dist/js/react-simulator-renderer.js

方式 2:unpkg

https://unpkg.com/@alilc/lowcode-engine@1.0.0/dist/js/engine-core.js

https://unpkg.com/@alilc/lowcode-react-simulator-renderer@1.0.0/dist/js/react-simulator-renderer.js

方式 3:jsdelivr

https://cdn.jsdelivr.net/npm/@alilc/lowcode-engine@1.0.0/dist/js/engine-core.js

https://cdn.jsdelivr.net/npm/@alilc/lowcode-react-simulator-renderer@1.0.0/dist/js/react-simulator-renderer.js

方式 4:使用自有 cdn

将源码中 packages/engine/dist 和 packages/(react|rax)-simulator-renderer/dist 下的文件传至你的 cdn 提供商

🔗 相关链接

💻 本地调试

$ git clone git@github.com:alibaba/lowcode-engine.git
$ cd lowcode-engine
$ npm install
$ npm run setup
$ npm start

📢 npm 访问速度较慢,阿里员工可以使用 tnpm,其他同学建议使用 cnpm 或者指定镜像 registry。

📢 node 版本限定在 14

📢 windows 环境必须使用 WSL,其他终端不保证能正常运行

lowcode-engine 启动后,提供了几个 umd 文件,可以结合 lowcode-demo 项目做调试,文件代理规则参考这里

相关导航

暂无评论

暂无评论...